Badges [ 8 ] [-]
Activity Stream [+]
Ideas Contributed [ 6 ] [+]
The jsonp callback should be 'callback' not 'jsonp' there is no reason you can't have both, but almost every single site that uses jsonp uses callback as the parameter, using something weird prevents people from easily making apps.
the api should simply ignore any parameter it doesn't understand instead of throwing an error. For example jquery will append _=randomNumber to prevent caching of jsonp by the browser. This feature breaks that.
API keys are a barrier to entry, and are somewhat pointless for web apps where anyone can view source and grab a key
'for' and 'in' are reserved words in JavasSript avoiding these words in the parameter names would probably be a good idea, same thing with 'get' which could cause confusion with the http verb.
The application that we made in Boston for the national day of civic hacking http://calvinmetcalf.github.io/CodeForBoston-Census/
I through together a version hosted on Openshift that allows deep linking to specific views.
This ended up being much longer then I intended so I posted it as a gist over here https://gist.github.com/calvinmetcalf/5721819
Don't be clever, take the conventions of other popular rest APIs as a guide, it's still better then 90% of government.